Urdu Español
Inglés English Deutsch Deutsch Español Español français Français Italiano Italiano Nederlands Nederlands Español Português Русский Русский griego Ελληνικά
Login



 
Bienvenido a Jumi! >> Noticias >> Jumi paquete lanzado 2.0.0

La próxima generación de extensiones JUMI de código personalizado para Joomla! 1.5 fue dado a conocer hoy.

No se presenta como un paquete. Eso no sólo significa que todas las extensiones JUMI para Joomla! 1.5 se distibuted como un paquete, pero también significa - lo que es más importante - que también se instalan como una sola entidad.

Las extensiones individuales-ya sea un plugin o un módulo o un nuevo componente Jumi-también pueden colaborar muy estrechamente entre sí y compartir los recursos de código personalizado.

Debido a que hay además gran número de las versiones anteriores existía el paquete de Jumi se le dio la versión de lanzamiento 2.0.0 número.

Novedades

  • cualquier extensión Jumi puede incluir en Joomla! código almacenado en un archivo o en una tabla de base de datos de componentes,
  • módulo y componente puede incluir el código directamente por escrito,
  • inclusión de un archivo / registro y el código escrito no son mutuamente excluyentes: se puede utilizar el código almacenado o código escrito, o ambos a la vez,
  • Cada extensión tiene su propio archivo de idioma para que pueda ser fácil de traducir.

Observaciones sobre la compatibilidad con versiones anteriores

Jumi lector tiene la completa compatibilidad con versiones anteriores de plugins JUMI.

Jumi módulo posee completa compatibilidad demasiado, salvo argumentos función de los valores.

Hasta ahora, los argumentos fueron inputed en un campo de parámetro del módulo como éste

[Arg1] [arg2] ... [argN]

y se recuperaron en el script PHP en $ jumi [] matriz.

El campo de parámetros del módulo se mantiene y que ha logrado crecer y cambiar su significado. En el campo del módulo "código escrito" se puede escribir los códigos completos (texto plano, html, php, javascript) que ahora los valores y no sólo como antes.

Así que si usted desea utilizar su antiguo php que contengan argumentos en el nuevo Jumi módulo se puede hacer eso. Sólo tiene que escribir en el "código escrito" sobre el terreno esto (al menos):

<? Php
$ Jumi = array (arg1, arg2, ..., argN);
>

Conclusión

Nosotros, los desarrolladores, esperamos que disfrute de TNG Jumi como lo hizo con las versiones anteriores de extensión JUMI!